Buick Century ABS Light After New Pads And Rotors
Live Chat:
Please. Today my Buick Century had a break rotor and break pads change, a complete new set. A few hours later I noticed that the
anti-lock light stayed on while I was driving. What is the problem? my car is 1994.

It is possible that when doing the brake job, they may have damaged an ABS wheel speed sensor or wiring to one of the front wheel speed sensors. I would take it right back to them and tell them this started right after the repairs. Most shops will give it back to that
mechanic and he will check it out real quick.

Thanks! If there was a damage to the ABS wheel speed sensor etc, will it cost me a lot for the mechanic to fix this problem? How easy or hard are such kinds of problems?

If he damaged something, they would have to repair it fro free. It may just be a loose connector or pinched wire. That would take a few minutes to fix. A faulty front wheel speed sensor can run a few hundred dollars.

Thanks again. I hope it's an easy problem to fix. Hope that the problem is not about a faulty front wheel speed sensor. If that turns out to be the case I guess I've to spend a few hundred dollars to fix the problem. Right? Or, will the mechanic take care of it? I'm a client and they know me well, if that can help.

If you are a good customer, they will fix a small wiring repair for free. If the sensor went bad as a coinsidesnse, they may work a deal with you at a discount, since it happened right after their work.

That is a helpful answer and thank you very much. I'll be going back to the mechanic shop early in the morning tomorrow. By the way, the break was working fine.

More Car Repair Help



Contact Us © Copyright 2006 . GreatAutoHelp.com