I have a 2003 Tahoe that the ABS will come on just as you near a complete stop. What should I look for?
2003 Chevrolet Tahoe 5.3

I did replace the left front wheel bearing approx 1 year ago. It did not fail, but did have a little
movement. Problem seemed to start about a month later. This is a 4x4.
Answer:
The most common cause for this is a bad front wheel speed sensor, or the mounting surface of the sensor to the hub has some corrosion on it, thus making the air gap between the sensor and reluctor wheel in the bearing too great.

I asked about the turning because if that were the case, then i would suspect a faulty harness to one on of the front sensors. The wires break inside the insulation and cause this problem when slowing as turning.

I would suspect that the problem is in the other side that has not been replaced. You can remove the speed sensor, clean the mounting surfaces of any rust. Removing the sensor to do this would also indicate a bad sensor if you remove the sensor and the outer sleeve of the sensor stays in the hub.
Chevy Tahoe ABS Brakes At Slow Speeds
2005 CHEVROLET SILVERADO. Engine size = 4.3L V6 Vortec.
Did a FRONT END ALIGNMENT, LOOSE LOWER CONTROL ARM, REPLACED WORN ROTORS.

Question: BRAKE PEDAL WILL VIBRATE WHEN ALMOST STOPPED. FOUND CRACKED WHEEL SPEED SENSOR. CAN I REPLACE THE SENSOR ITSELF WITH DORMAN PART # 970011, OR SHOULD THE ENTIRE WHEEL HUB ASSEMBLY BE REPLACED?

Answer:
Yes you can replace the sensor. These are common for causing this problem you have. If the sensor broke and a piece is missing, then it may have fallen into the hub. If that happened, it will destroy the hub.

If the outer casing of the sensor just broke off and it is stuck in the mounting hole of the hub, then you can just pry that piece out and you will be ok. With new sensor in hand you will be able to tell if any pieces are missing and possibly in the hub.

Depending on how the sensor is cracked, suggest looking in the sensor mounting hole of the hub while turning the hub to look at the toothed ring and make sure it is not damaged, or possibly caused the sensor to crack.I would suggest a GM sensor. Have seen a few times where an aftermarket sensor can cause different problems because they do not send out a perfect signal, but that is not real common. Up to you.

More Car Repair Help



Contact Us © Copyright 2006 . GreatAutoHelp.com