2007 Chevrolet Equinox AWD. Engine size 3.4L.
We installed a new 20 amp fuse for the auxiliary power outlets (there are 2 in the 2007 Equinox).
Question: Both of the auxiliary power outlets do not work. I checked the fuse and saw that it was blown. I replaced it with a new fuse (20 amp) and it immediately blew again. Still do not have outlets working.

Answer:
Be sure there that you do not have anything plugged into the power outlets. We have seen many times where a phone charger or radar detector is shorted out causing the fuse to blow. Make sure there are no coins in either of them as well . Kids love to put pennies in those outlets.

If this checks out good and you did not find the problem, then you are going to have to start looking for a shorted wire. It would be the power feed wire to either one, between the outlet and the fuse box. The center console would need to be removed to start tracing down wires.
2005 Chevy Equinox.
Question: I have a 2005 chevy Equinox. When I come to a stop light or stop sign and step on brake pedal it stops fine but just before it comes to a complete stop the pedal makes a noise.

You can hear it and it only does it one time. Took it to the garage and they said it sounds like
ABS kicks in but no light on dash comes on and no codes. Fuses are good.

Answer:
Yes, most likely the problem is with one of the front wheel speed sensors. They are part of each front wheel bearing / hub. When they fail, the speed signal to the computer drops off at a certain speed. This causes the ABS brakes to activate. It happens so quick that the computer cannot even catch it to set a warning light or codes.

Without
ABS codes, it will be difficult to determine which one is acting up. A scan tool to watch speed sensor data is needed to catch the one that is dropping off. The better tools even have a record function to review real time data in small increments.

Another possibility is a broken wire to one of the front sensors. But these usually act up when turning the steering wheel, because it stretches the wires. You could take apart the small harness to each front speed sensor and check for corroded wires. There are just 2 wires for each. They run along the lower control arm.
Chevrolet Equinox Power Outlets Dead- ABS Brakes Problem

More Car Repair Help



Contact Us © Copyright 2006 . GreatAutoHelp.com